НОВЫЙ САЙТ www.MAGAZKAT.ru

новая версия программы MAGAZKA & MAGAZKA (NS)

Мы ждем Вас !


Как добавить весы в магазку? драйверы не Атол, но он есть и код обработки для весов.
(1 чел.) (1) Гость
В этом форуме Вы можете задать любые вопросы по работе программы, особенно если они могут быть полезны и другим пользователям программы. Мы обязательно поможем Вам использовать программу на все 100%.
ВнизСтраница: 1
Сообщения темы: Как добавить весы в магазку? драйверы не Атол, но он есть и код обработки для весов.
#10444
Как добавить весы в магазку? драйверы не Атол, но он есть и код обработки для весов. 3 г., 4 мес. назад Репутация: 2
Нужно чтоб при подборе товара в документы 1с происходил опрос и считывания с весов информации. Драйвер Атоловский не подходит. Есть драйвер для весов , весы через ком порт подключены и установлены на компьютере. Есть также код для 1С от разработчиков драйвера принтера. А вот куда этот код вставлять , вопрос?
kamil
Завсегдатай
Постов: 187
graphgraph
Баллы: 9750
graphgraph
Пользователь вне форума Кликните здесь, чтобы посмотреть профиль этого пользователя
Для добавления сообщений Вы должны зарегистрироваться или авторизоваться
 
#10445
Re: Как добавить весы в магазку? драйверы не Атол, но он есть и код обработки для весов. 3 г., 4 мес. назад Репутация: 43
"Код для 1С" это что ? весы марка какая ?
admin
Tatitutu - это судьба (с)
Администратор
Постов: 2458
graph
Баллы: 99812
graph
Пользователь вне форума Кликните здесь, чтобы посмотреть профиль этого пользователя
Пол: Мужской wwwmagazkacom magazka.com Страна, город: Россия Дата рождения: 12/07
Для добавления сообщений Вы должны зарегистрироваться или авторизоваться
 
#10446
Re: Как добавить весы в магазку? драйверы не Атол, но он есть и код обработки для весов. 3 г., 4 мес. назад Репутация: 2
весы марка ВТА-60,если это чем то поможет. Код для 1С 7,7 поставляемый с драйвером:

// Для удачного копирования текста в конфигуратор 1С 7.7
// в программе и в конфигураторе выберите раскладку "RU".
//версия платформы 1С 7.7
Перем Весы Экспорт;
Перем Рез; // переменная в которую записываеся сообщение о ошибке
Перем ИмяВесов;

Процедура КнопкаПолучитьВесНажатие()
Перем Вес; // вес в граммах (или в килограммах, если весы больше тонны)
Перем Цена; // поддерживаются не все типы весов (только торговые)
Перем Стоимость; // поддерживаются не все типы весов (только торговые)
Перем ВесСтабильный; // если 1 = вес на весах успокоился, 0 = не успокоился

//Получаем вес с весов
Рез = Весы.GetWeight(ИмяВесов, Вес, Цена, Стоимость, ВесСтабильный );

Если Рез <> 0 Тогда
Сообщить ( "Ошибка: "+ Строка( Рез ));
Иначе
Сообщить ( "Вес: "+ Строка(Вес) +
" Цена: "+ Строка(Цена) +
" Стоимость: "+ Строка(Стоимость)+
" Вес стабильный: "+ Строка(ВесСтабильный));
КонецЕсли;
КонецПроцедуры


Процедура КнопкаНажатьТАРАНажатие()
Рез = Весы.PressT( ИмяВесов );
Если Рез <> 0 Тогда
Сообщить ( "Ошибка: "+ Строка( Рез ));
КонецЕсли;
КонецПроцедуры


Процедура КнопкаОтправитьЦенуНажатие()
Рез = Весы.SetPrice( ИмяВесов, 12345 );
Если Рез <> 0 Тогда
Сообщить ( "Ошибка: "+ Строка( Рез ));
КонецЕсли;
КонецПроцедуры


///////////////////////////////////////////////////////////////////////
//Инициализация при открытии обработки
ИмяВесов = "1";

// Подключаем к 1С СОМ-обьект для работы с весами
Попытка
ПодключитьВнешнююКомпоненту("AddIn.UniproScalesComSrv");
//если драйвер не зарегистрирован с помощью regsvr32, тогда так:
//ЗагрузитьВнешнююКомпоненту("C:\ScalesComSrv\v3.3.1\UniproScalesComServer.dll");
//////////////////
// Создаем объект "ВЕСЫ"
Весы = СоздатьОбъект ("AddIn.UniproScalesComSrv");
Исключение
Сообщить("Компонента для работы з весами НЕ загружена", "!!");
КонецПопытки;
kamil
Завсегдатай
Постов: 187
graphgraph
Баллы: 9750
graphgraph
Пользователь вне форума Кликните здесь, чтобы посмотреть профиль этого пользователя
Для добавления сообщений Вы должны зарегистрироваться или авторизоваться
 
ВверхСтраница: 1
Модераторы: akzagam, ProstoSkazka, Potovskiy, aleksiy55